To avoid the reverse engineering of script applications, a lot of developers encode their program code with tools like ionCube PHP Encoder to make it human unreadable. The aforementioned is valid for paid apps in particular, because anybody would be able to use and modify the unprotected code without having to pay the required license fees. When you obtain web software encoded with ionCube PHP Encoder, you can use it without any problems as long as a software tool known as ionCube Loader is installed on the web hosting server. This loader allows you to run encrypted files and you'll often find it on the list of prerequisites for a certain script app to be set up. Because the encrypted files are already precompiled, they're generally executed faster and this can raise the general speed of your website.
IonCube in Website Hosting
IonCube Loader is supplied with each Linux website hosting service that we provide and you are able to activate it anytime with just a few clicks, so you can employ script apps that require it. You'll be able to do that from the PHP Configuration section of the Hepsia Control Panel and all it'll take to enable or disable ionCube is to click a single button. The change takes effect in a minute, which means that you're able to go ahead and install the app that you'd like without delay. The same section allows you to change the PHP version which is active for your account, as we support numerous versions on our state-of-the-art cloud platform. In case you switch to a release that you haven't used so far, you'll need to activate ionCube Loader again. Experienced users can use a php.ini file in a specific domain folder in order to set a PHP release different from the one for the whole account or enable/disable ionCube Loader.
IonCube in Semi-dedicated Hosting
In case you obtain a semi-dedicated server plan from us, you will be able to employ any script-driven app which needs ionCube Loader due to the fact that the tool comes with all servers which are a part of our modern cloud web hosting platform. In addition, we support several versions of PHP, so if you move from PHP 4 to 5.2 or 5.3, for example, you can activate ionCube for that particular version with only a click from your Hepsia Control Panel. Our platform will remember your choice, so in case you move back to the previous version of PHP, the software instrument will already be active. For more tech-savvy users, we also provide the option to pick the PHP version and whether ionCube will be active or not for a particular domain name without altering the settings for the whole website hosting account. This can be done by putting a php.ini file within a domain folder with a few lines of code.